Judy Security Outage

Incident Report for Judy Security

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:09 EDT

Investigating

We are currently experiencing a temporary outage affecting some of Judy Security’s pillars due to a global AWS outage. Our team is actively monitoring the situation and working to restore full functionality as quickly as possible. We will continue to provide updates as they become available. We sincerely apologize for the inconvenience and appreciate your patience during this time.
Posted Oct 20, 2025 - 09:53 EDT
This incident affected: Password Manager, Judy, Champion Dashboard, and Endpoint Protection.