Judy's Portal

Incident Report for Judy Security

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 12:10 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 12:10 EDT

Identified

There is an outage impacting our Judy's Portal. We are actively working to address this issue and will provide updates as they come along. Thank you for your patience as we continue to look into this issue.
Posted Apr 14, 2025 - 10:39 EDT
This incident affected: Champion Dashboard.