DNSFilter Dashboard Performance Issue
Incident Report for Judy Security
Resolved
This incident has been resolved.
Posted May 06, 2024 - 19:27 EDT
Monitoring
Our engineering team is currently investigating an issue which is causing Slowness when navigating or logging into the DNSFilter dashboard. Updated status will be provided as soon as possible.
Posted May 06, 2024 - 11:05 EDT
This incident affected: Anti-Phishing.