Infrastructure Improvements & Maintenance
Incident Report for Judy Security
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 15:14 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 14, 2024 - 10:26 EST
Monitoring
We are currently updating Judy’s backend systems to enhance overall performance and reliability. During this time, some components of Judy may be temporarily inaccessible. The process is taking longer than anticipated, but please rest assured our team is working diligently to resolve this issue as soon as possible.

We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 13, 2024 - 21:53 EST
This incident affected: Judy's Team Blue.