Temporary Outage - December 17th, 2023
Incident Report for Judy Security
Resolved
We have resolved the incident that affected user log in to Judy. We apologize for the inconvenience.
Posted Dec 17, 2023 - 14:40 EST
Investigating
Judy's backend systems are currently down for maintenance, the engineering team is working on a solution.
Posted Dec 17, 2023 - 14:37 EST
This incident affected: Password Manager, Judy, Champion Dashboard, and Mobile App.